2013-08-22

Skype Multiarch en Debian Wheezy de 64bits

Terminando de cuadrar la maquina fui a instalar Skype y me encontré un inconveniente que no existe un instalador para 64bits sino que solo existe un multiarch (múltiples arquitecturas), que no es más sino un paquete para 32bits. Esto genera que no sea compatible al momento de instalarlo.

Como siempre todo se puede arreglar fácilmente, buscando en la wiki de Debian, encontré que el problema se presenta porque el comando de instalación no esta habilitado a múltiples arquitecturas por lo que toca indicarlo así:

root@localhost:~# dpkg --add-architecture i386

Después actualizar e instalar el paquete de Skype así

root@localhost:~# apt-get update
root@localhost:~# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
root@localhost:~# dpkg -i skype-install.deb

Una vez termine es mejor forzar a corregir los errores de las dependencias e instalar un paquete de sonido que es muy factible que falte, lo cual lo haces así:

root@localhost:~# apt-get install -f
root@localhost:~# apt-get install libpulse0:i386

Espero que les sirva.